Men

SuitsMen BriefsBoxer Shorts

Home

White CarpetWallpaperWhite WallpaperToilet SeatsWhite NightstandsTablesPink CarpetParquetRugOffice DeskPaintPaintingsNightstandsIKEA DrapesGreen CarpetLightingGray WallpaperGray CarpetFurnitureDresserCouchDrapesChandelierChairsBlue CarpetBeige CarpetBathroom FurnitureBedXiaomi TelephoneSoundbarsTabletsXiaomi SmartwatchesSamsung SmartwatchesSSD HarddisksSpeakersSmartwatchesTelephoneSamsung TelephoneLENOVO LaptopsMotorola TelephoneLaptopsJBL SpeakersHuawei SmartwatchesHP LaptopsJBL HeadphonesHonor TelephoneDell LaptopsHeadphonesApple LaptopsApple SmartwatchesTelevisionPlaystation 5RouterMouseHuawei Laptops

Kids

PuppetsToysPhilips Avent Baby BottlesLANSINOH Baby BottlesKids Stroller & PushchairKids’ BikesKids SandalsKids Car SeatKids SneakersKids BootsKids ShoesKids SweatsuitsBaby BottlesBaby & Toddler ToysBarbie Puppets

Women

White DressesWhite T-ShirtsWatchesEarringsWhite JeansSwarovski JewelryTriumph BrasSwimsuitsSunglassesT-ShirtsTrousersSweatshirtsSwimsuitsEarringsRingsSweatpantsPandora JewelryPolo T-ShirtsKids WatchesPink DressesSkirtsPajamasSocksNike SweatpantsNecklacesKids PajamasKids SunglassesKids EarringsNike SocksNike T-ShirtsWhite TrousersKids Polo T-ShirtsMANGO DressesJeansEarringsShortsCharmsDressesJewelryBrasBlousesBlack JeansBlack Dressesadidas TrousersPandora RingsBikini

Beauty

ShampoosLip GlossesNailLashesMakeupLipsticksMascarasLattafa Fragrances and DeodorantsEyelinersFragrances and DeodorantsCollagenBlue NailBeautyAvon Fragrances and DeodorantsPhilips EpilatorEpilatorBraun Epilator

Electronics

Xiaomi Robot Vacuum CleanerVileda MopsWashing MachineVacuum CleanerRowenta Upright Vacuum CleanersUpright Vacuum CleanersRefrigeratorPhilips Upright Vacuum CleanersRobot Vacuum CleanerSandwich MakersPillowsMopsMultipurpose CookerMicrowave OvenFanDehumidifierFabric SoftenersBosch Upright Vacuum CleanersBedding SetRoborock Robot Vacuum CleanerMixerLeifheit Mops

Supermarket

Tchibo CoffeePistachioPastaLays ChipsLavAzza CoffeeJacobs CoffeeDavidoff CoffeeChipsCerealsCoffeeTurmericConfectioneryBulgurWater

Shoes & Bags

TEVA SandalsWhite SandalsWhite BootsTimberland BootsWhite Ballerina FlatsTommy Hilfiger SandalsSports ShoesWhite ShoesSkechers SandalsUGG BootsStilettosPuma BootsSandalsShoesLuggageBootsWalletsGeox BootsGold-colored SandalsNike CramponsGuess SandalsGold-colored ShoesEspadrillesLoafer ShoesCramponsCrocs AccessoryBum BagsBootsBrown ShoesBlack Ballerina FlatsBeige ShoesBeige SandalsBallerina FlatsBackpacksadidas BootsBagsCasual ShoesBlack ShoesSneakersadidas Sneakers

Popular Brands

ZzzquilXerjoffVera WangXiaomiTom TailorVivoYves Saint LaurentTissotVagabondValentinoVogueTakisTamagotchiUGGVichySupradynTESLASteve MaddenSPONGEBOBSinsayTom FordSkullcandyThe OrdinaryTommy HilfigerUnder ArmourStar WarsSanteSTIHLTriumphTimberlandYves RocherVersaceSephoraVivienne WestwoodSonicRemaxVansSamsoniteSol de JaneiroThe North FaceRoborockRoyal CaninSkechersTEFALStradivariusSudocremRAZERRed BullTCLRalph LaurenPringlesTchiboStanleyPeppa PigRedoxonSeikoPARKSIDESanoSHEINRitualsSamsungPandoraSwarovskiPHILIPP PLEINSalomonPalm AngelsRevoxPolaroidOsteocarePradaPaniniOppoNutellaONLYPrimarkPaco RabanneOneplusNintendoOriflameNutribulletPampersNextNokiaMYPROTEINPumaPhilipsStarbucksNespressoMoroccanoilMonclerOlaplexMontaleMoon BootPentiMilkaMomaxSpidermanMieleNikeMilwaukeeMilkshakeMylineMichelinMonopolyNew BalanceMichael KorsMaison MargielaMedicubeMotorolaLinexMakitaMayorallogitechMANGOMinisoMacLaysLC WaikikiLattafaLego NinjagoLanvinKinderLacosteL'OccitaneLaneigeKIKOLEGOLancomeKarl LagerfeldKerastaseJuicy CoutureLa Roche PosayK18LavAzzaJumboJORDANJimmy ChooISABEL MARANTJean Paul GaultierIVATHERMJBLLENOVOHugo BossHusqvarnaHuggiesIKEAKarcherhokaHuda BeautyHuaweiHonorHello KittyHermesHerbalifeHOT WHEELSHikvisionHarry PotterGoProGucciGNCGolden GooseHugoGivenchyGEROVITALGiorgio ArmaniGuessGarminFortunaFerrero RocherGantGAPFURLAGeoxFENTY BEAUTYEstee LauderElectroluxEssenceEmporio ArmaniEccoDYSONElseveDr MartensDoTERRADoritosDunhillDurexDoppelherzEnglish HomeDJIDieselDeeZeeDiorDecathlonDelonghiDewaltDellCybexCroppDesigualDavid BeckhamCupioFarmasiCrocsColmarColumbiaCocosolisChristian DiorConverseChanelCifCarrefourcharlotte tilburyCarharttCeraVeCasioCartierCarolina HerreraBurberryCalvin KleinBritney SpearsBioSilBuffaloBirkenstockBoschBiodermaBALMAINBekoBatmanBalenciagaBepanthenBABY BREZZABarbieASOSBabylissArmaniBershkaASUSAriana GrandeAptamilAvonArielAntonio BanderasAmouageAsicsCOSAveneAmiriBigottiAppleAmdALEXANDER MCQUEENAlfaparfAldoAlwaysadidas

Sports & Outdoor

TennisTentPoolElectric BikeFootball JerseysElectric ScooterFootballBicycleBasketball ProductsSkateboardPilatesHoverboard

Books & Stationery

Pencil CasesNovelNotebooksFolderColoring BooksChildren's StorybooksBookmarkBooksColored PencilsBallpoint PensAgendaPuzzleManga

Multicolor Chargers

6486+ item(s)
Choice9 back 65W US UK TINSOL PD 65W Ultra-thin Gallium Nitride Charger US/EU...

Choice back 65W US UK TINSOL PD 65W Ultra-thin Gallium Nitride Charger US/EU/KR/UK USB-C Dual-Port Fast Cha

Lowest price in 30 days

Free shipping
Checkout Discount 30% Off

Lowest price in 30 days

Special Deals
73.58
51.51SAR
Choice Black Type-C Cable-A Fast Charging Cable For Huawei Watch 3 GT2 GT3 PR...

Choice Black Type-C Cable-A Fast Charging Cable For Huawei Watch 3 GT2 GT3 PRO USB Magnetic Charger For Hua

Lowest price in 30 days

Free shipping
Checkout Discount 25% Off

Lowest price in 30 days

Special Deals
24.90
18.67SAR
Choice1 US 6 in 1 USB Fast Charger Power Strip 1m Cord Desktop Charging Stati...

Choice US 6 in 1 USB Fast Charger Power Strip 1m Cord Desktop Charging Station Fast Charging USB HUB Adapte

Lowest price in 14 days

Free shipping
Checkout Discount 25% Off

Lowest price in 14 days

Special Deals
30.21
22.66SAR
Alfanar 20W Fast USB Charger 1 Port Type C - Power Delivery Support (PD), GaN...

Alfanar 20W Fast USB Charger 1 Port Type C - Power Delivery Support (PD), GaN Technology

Free shipping

-9%

69.98
SAR
76.98
Choice samsung EU Black Set Original Samsung 25w Charger Type C Super Fast Ch...

Choice samsung EU Black Set Original Samsung 25w Charger Type C Super Fast Charge Adapter For Galaxy A12 A1

4.8
(75)

Lowest price in 7 days

Free shipping
Checkout Discount 25% Off

Lowest price in 7 days

Special Deals
45.79
34.34SAR
KASTWAVE 2 Pack USB-C Male to Lightning Female Adapter, USB Type C to Lightni...

KASTWAVE 2 Pack USB-C Male to Lightning Female Adapter, USB Type C to Lightning Connector for iPhone 15/15 Pl

Free shipping

-9%

75.60
SAR
83.16
Choice Black US USB Type C Charger 30W 3 Port Fast Charging Phone Charger Ada...

Choice Black US USB Type C Charger 30W 3 Port Fast Charging Phone Charger Adapter For iPhone Samsung Xiaomi

Lowest price in 30 days

Free shipping
Checkout Discount 25% Off

Lowest price in 30 days

Special Deals
28.61
21.46SAR
Choice3 XIAOMI EU Plug Add 2M XIAOMI 90W Charger Original Mi Turbo Fast Charg...

Choice XIAOMI EU Plug Add 2M XIAOMI 90W Charger Original Mi Turbo Fast Charging Adapter EU US Xiaomi 17 Ult

Free shipping
Checkout Discount 25% Off
Free shipping
Special Deals
63.42
47.56SAR
Choice4 EU Charger and Cable PD 40W Type C Charger Fast Charging Adapter For ...

Choice EU Charger and Cable PD 40W Type C Charger Fast Charging Adapter For iPhone 17 13 11 12 14 15 16 Pro

Lowest price in 14 days

Free shipping
Checkout Discount 25% Off

Lowest price in 14 days

Special Deals
25.29
18.97SAR
Choice5 EU Charger 1M Cable Original 65W Supervooc Fast Charger For OPPO K13 ...

Choice EU Charger 1M Cable Original 65W Supervooc Fast Charger For OPPO K13 K12 K11 K10 Turbo Reno 14 13 12

Lowest price in 30 days

Free shipping
Checkout Discount 25% Off

Lowest price in 30 days

Special Deals
43.64
32.73SAR
Anker Stuy Anker Zolo USB C Charger Block, 4-Port Wall Adapter with 50W Max O...

Anker Stuy Anker Zolo USB C Charger Block, 4-Port Wall Adapter with 50W Max Output, 2 USB-C and 2 USB-A, Compac

Free shipping
152.20
SAR
Choice Yellow-US 240W GaN 5 in 1 Fast Charging Phone Charger USB C Charger Po...

Choice Yellow-US 240W GaN 5 in 1 Fast Charging Phone Charger USB C Charger Power Adapter Type C EU/US Plug

Lowest price in 14 days

Free shipping
Checkout Discount 25% Off

Lowest price in 14 days

Special Deals
25.91
19.43SAR
Hagibis USB-C Adapter, Dual-Sided Magnetic Ring Female to Female USB Typ-C Co...

Hagibis USB-C Adapter, Dual-Sided Magnetic Ring Female to Female USB Typ-C Converter, 240W Fast Char

Free shipping

-9%

162.98
SAR
179.28
AILKIN USB C Splitter 2 in 1 Android USB C Headphone & Charger Adapter Aux Do...

AILKIN USB C Splitter 2 in 1 Android USB C Headphone & Charger Adapter Aux Dongle

Free shipping

-9%

70.88
SAR
77.97
Choice white EU 65W Super Fast Charge Type C USB Phone Charger With Retractab...

Choice white EU 65W Super Fast Charge Type C USB Phone Charger With Retractable USB C Cable For Iphone 17 1

Lowest price in 14 days

Free shipping
Checkout Discount 25% Off

Lowest price in 14 days

Special Deals
43.19
32.39SAR
Choice EU PD45W USB Type C Phone Fast Charger QC3.0 Super Fast Charging EU/UK...

Choice EU PD45W USB Type C Phone Fast Charger QC3.0 Super Fast Charging EU/UK/US Plug Adapter For IPhone15/

Lowest price in 14 days

Free shipping
Checkout Discount 25% Off

Lowest price in 14 days

Special Deals
31.02
23.26SAR
Choice 1m Cable - Kit EU Charger and Cable 67W Super Fast USB Charger for Xia...

Choice 1m Cable - Kit EU Charger and Cable 67W Super Fast USB Charger for Xiaomi 11 12 Lite 13T 14T Redmi N

Lowest price in 7 days

Free shipping
Checkout Discount 25% Off

Lowest price in 7 days

Special Deals
31.83
23.87SAR
GENERAL Micro USB to USB C Adapter, Type C Female to Micro B Male Charger Con...

GENERAL Micro USB to USB C Adapter, Type C Female to Micro B Male Charger Connector Converter for Galaxy S7/

Free shipping
50.50
SAR
Choice3 Black-3pcs 3/5pcs Universal Plastic Magnet Plate for Magsafe Wireless...

Choice Black-3pcs 3/5pcs Universal Plastic Magnet Plate for Magsafe Wireless Charging Magnet Ring Magnetic

Lowest price in 14 days

Free shipping
Checkout Discount 25% Off

Lowest price in 14 days

Special Deals
27.39
20.54SAR
Choice EU Plug - 1.5m Cable 6A 67W Ultra Fast Charger For Xiaomi 11 12 Lite 1...

Choice EU Plug - 1.5m Cable 6A 67W Ultra Fast Charger For Xiaomi 11 12 Lite 13T 14T 15 17 Redmi Note 10 11T

Lowest price in 14 days

Free shipping
Checkout Discount 25% Off

Lowest price in 14 days

Special Deals
33.71
25.28SAR
Haoano iPhone OTG Adapter, USB 3.0 Female to Lightning Male Adapter OTG Dongle

Haoano iPhone OTG Adapter, USB 3.0 Female to Lightning Male Adapter OTG Dongle

Free shipping

-9%

62.28
SAR
68.51
GENERAL Universal Adapter, Worldwide Travel Plug Adaptor with 2 USB A and 2 U...

GENERAL Universal Adapter, Worldwide Travel Plug Adaptor with 2 USB A and 2 USB C Ports, PD20W Fast Charging

Free shipping
137.98
SAR
Choice EU ( 15-17 Series) PD 30W USB C Fast Charging For iPhone 13 12 11 14 P...

Choice EU ( 15-17 Series) PD 30W USB C Fast Charging For iPhone 13 12 11 14 Pro Max 7 8 Plus Mini XS XR X Q

Free shipping
Checkout Discount 25% Off
Free shipping
Special Deals
36.07
27.05SAR
SKEIDO Smartwatch Dock Charger Adapter USB Charging Cable Power Charge Cord f...

SKEIDO Smartwatch Dock Charger Adapter USB Charging Cable Power Charge Cord for Huawei Honor Smart W

Free shipping

-9%

123.08
SAR
135.39
essager 20W White EU Plug Mini 20W USB Type C Charger PD Fast Charging for iP...

essager 20W White EU Plug Mini 20W USB Type C Charger PD Fast Charging for iPhone 16 15 14 P

Lowest price in 14 days

Free shipping
Checkout Discount 25% Off

Lowest price in 14 days

Special Deals
30.79
23.09SAR
GENERAL Adapter Charger, DC 21V Replacement Charger for Charging for Lithium ...

GENERAL Adapter Charger, DC 21V Replacement Charger for Charging for Lithium Battery(British regulatory)

Free shipping

-9%

95.09
SAR
104.60
Choice Korean Plug 800W USB C GaN Charger 100W PD3.0 PPS QC3.0 10-Port Fast C...

Choice Korean Plug 800W USB C GaN Charger 100W PD3.0 PPS QC3.0 10-Port Fast Charging Station for iPhone 16/

Lowest price in 14 days

Free shipping
Checkout Discount 30% Off

Lowest price in 14 days

Special Deals
158.79
111.15SAR
Naxifly USB C Charger, 25W Fast Charge Wall Plug, 2 Ports PD&QC 3.0 Fast Char...

Naxifly USB C Charger, 25W Fast Charge Wall Plug, 2 Ports PD&QC 3.0 Fast Charger Plug Compatible for iPhone

Free shipping

-9%

84.28
SAR
92.71
choice2 EU Plug Black 45W PD Fast Charging For Samsung S22 S23 Ultra Note10 P...

Choice EU Plug Black 45W PD Fast Charging For Samsung S22 S23 Ultra Note10 Plus Mobile Phone USB Type C Cab

Lowest price in 14 days

Free shipping
Checkout Discount 25% Off

Lowest price in 14 days

Special Deals
31.06
23.29SAR
Choice3 US White Dual Ports USB Type C Charger Fast Charging 45W QC PD 3.0 Tr...

Choice US White Dual Ports USB Type C Charger Fast Charging 45W QC PD 3.0 Travel Wall Charger Adpater Fast

Lowest price in 7 days

Free shipping
Checkout Discount 25% Off

Lowest price in 7 days

Special Deals
29.88
22.41SAR
Choice4 Only US Charger Original PD 68W Fast Charger For Samsung Xiaomi Onepl...

Choice Only US Charger Original PD 68W Fast Charger For Samsung Xiaomi Oneplus Google Motorola Moto USB C P

Lowest price in 14 days

Free shipping
Checkout Discount 25% Off

Lowest price in 14 days

Special Deals
45.55
34.16SAR
Choice black USB Charger Cord Compatible with Hatteker RFC-588 RSCX-7856 RFC-...

Choice black USB Charger Cord Compatible with Hatteker RFC-588 RSCX-7856 RFC-598 RFC-690 RFC-692 RSCX-9598

Lowest price in 7 days

Free shipping
Checkout Discount 25% Off

Lowest price in 7 days

Special Deals
24.52
18.39SAR
Choice 1PCS KR Plug Purple 20W PD Korean USB C Type C Charger For iPhone 15 F...

Choice 1PCS KR Plug Purple 20W PD Korean USB C Type C Charger For iPhone 15 Fast Charging Cable For Xiaomi

Lowest price in 30 days

Free shipping
Checkout Discount 25% Off

Lowest price in 30 days

Special Deals
31.34
23.50SAR
GENERAL 100W Fast Charger with 8A USB-A to USB-C Cable Compatible with OnePlu...

GENERAL 100W Fast Charger with 8A USB-A to USB-C Cable Compatible with OnePlus 13/12/11/10 Series OPPO Realm

Free shipping
226.65
SAR
Choice PD 45W Charger Cable 45W Super Fast Charger & USB-C Data Cable - Porta...

Choice PD 45W Charger Cable 45W Super Fast Charger & USB-C Data Cable - Portable Adapter for Samsung for Ga

Lowest price in 30 days

Free shipping
Checkout Discount 25% Off

Lowest price in 30 days

Special Deals
32.81
24.61SAR
choice2 White 140W Digital Display Full-Charge Separator Al-Powered Recogniti...

Choice White 140W Digital Display Full-Charge Separator Al-Powered Recognition Of Current Separator For Aut

Lowest price in 30 days

Free shipping
Checkout Discount 25% Off

Lowest price in 30 days

Special Deals
56.31
42.23SAR
1...27...5354555657...97...138

Promotional items

Price

Quick Charge

Number of Ports

Reviews with images

Local delivery

Cross promotions

Trendyol Plus

Seller type

merchant-badges-info-tooltip-approve-seller-title
Official seller
This badge is awarded to sellers of widely recognized local and international brands.
Star seller
This badge is awarded to sellers providing high customer satisfaction and offering reliable, high-quality service over the past 6 months.
What is seller type?