Men

SuitsMen BriefsBoxer Shorts

Home

White CarpetWallpaperWhite WallpaperToilet SeatsWhite NightstandsTablesPink CarpetParquetRugOffice DeskPaintPaintingsNightstandsIKEA DrapesGreen CarpetLightingGray WallpaperGray CarpetFurnitureDresserCouchDrapesChandelierChairsBlue CarpetBeige CarpetBathroom FurnitureBedXiaomi TelephoneSoundbarsTabletsXiaomi SmartwatchesSamsung SmartwatchesSSD HarddisksSpeakersSmartwatchesTelephoneSamsung TelephoneLENOVO LaptopsMotorola TelephoneLaptopsJBL SpeakersHuawei SmartwatchesHP LaptopsJBL HeadphonesHonor TelephoneDell LaptopsHeadphonesApple LaptopsApple SmartwatchesTelevisionPlaystation 5RouterMouseHuawei Laptops

Kids

PuppetsToysPhilips Avent Baby BottlesLANSINOH Baby BottlesKids Stroller & PushchairKids’ BikesKids SandalsKids Car SeatKids SneakersKids BootsKids ShoesKids SweatsuitsBaby BottlesBaby & Toddler ToysBarbie Puppets

Women

White DressesWhite T-ShirtsWatchesEarringsWhite JeansSwarovski JewelryTriumph BrasSwimsuitsSunglassesT-ShirtsTrousersSweatshirtsSwimsuitsEarringsRingsSweatpantsPandora JewelryPolo T-ShirtsKids WatchesPink DressesSkirtsPajamasSocksNike SweatpantsNecklacesKids PajamasKids SunglassesKids EarringsNike SocksNike T-ShirtsWhite TrousersKids Polo T-ShirtsMANGO DressesJeansEarringsShortsCharmsDressesJewelryBrasBlousesBlack JeansBlack Dressesadidas TrousersPandora RingsBikini

Beauty

ShampoosLip GlossesNailLashesMakeupLipsticksMascarasLattafa Fragrances and DeodorantsEyelinersFragrances and DeodorantsCollagenBlue NailBeautyAvon Fragrances and DeodorantsPhilips EpilatorEpilatorBraun Epilator

Electronics

Xiaomi Robot Vacuum CleanerVileda MopsWashing MachineVacuum CleanerRowenta Upright Vacuum CleanersUpright Vacuum CleanersRefrigeratorPhilips Upright Vacuum CleanersRobot Vacuum CleanerSandwich MakersPillowsMopsMultipurpose CookerMicrowave OvenFanDehumidifierFabric SoftenersBosch Upright Vacuum CleanersBedding SetRoborock Robot Vacuum CleanerMixerLeifheit Mops

Supermarket

Tchibo CoffeePistachioPastaLays ChipsLavAzza CoffeeJacobs CoffeeDavidoff CoffeeChipsCerealsCoffeeTurmericConfectioneryBulgurWater

Shoes & Bags

TEVA SandalsWhite SandalsWhite BootsTimberland BootsWhite Ballerina FlatsTommy Hilfiger SandalsSports ShoesWhite ShoesSkechers SandalsUGG BootsStilettosPuma BootsSandalsShoesLuggageBootsWalletsGeox BootsGold-colored SandalsNike CramponsGuess SandalsGold-colored ShoesEspadrillesLoafer ShoesCramponsCrocs AccessoryBum BagsBootsBrown ShoesBlack Ballerina FlatsBeige ShoesBeige SandalsBallerina FlatsBackpacksadidas BootsBagsCasual ShoesBlack ShoesSneakersadidas Sneakers

Popular Brands

ZzzquilXerjoffVera WangXiaomiTom TailorVivoYves Saint LaurentTissotVagabondValentinoVogueTakisTamagotchiUGGVichySupradynTESLASteve MaddenSPONGEBOBSinsayTom FordSkullcandyThe OrdinaryTommy HilfigerUnder ArmourStar WarsSanteSTIHLTriumphTimberlandYves RocherVersaceSephoraVivienne WestwoodSonicRemaxVansSamsoniteSol de JaneiroThe North FaceRoborockRoyal CaninSkechersTEFALStradivariusSudocremRAZERRed BullTCLRalph LaurenPringlesTchiboStanleyPeppa PigRedoxonSeikoPARKSIDESanoSHEINRitualsSamsungPandoraSwarovskiPHILIPP PLEINSalomonPalm AngelsRevoxPolaroidOsteocarePradaPaniniOppoNutellaONLYPrimarkPaco RabanneOneplusNintendoOriflameNutribulletPampersNextNokiaMYPROTEINPumaPhilipsStarbucksNespressoMoroccanoilMonclerOlaplexMontaleMoon BootPentiMilkaMomaxSpidermanMieleNikeMilwaukeeMilkshakeMylineMichelinMonopolyNew BalanceMichael KorsMaison MargielaMedicubeMotorolaLinexMakitaMayorallogitechMANGOMinisoMacLaysLC WaikikiLattafaLego NinjagoLanvinKinderLacosteL'OccitaneLaneigeKIKOLEGOLancomeKarl LagerfeldKerastaseJuicy CoutureLa Roche PosayK18LavAzzaJumboJORDANJimmy ChooISABEL MARANTJean Paul GaultierIVATHERMJBLLENOVOHugo BossHusqvarnaHuggiesIKEAKarcherhokaHuda BeautyHuaweiHonorHello KittyHermesHerbalifeHOT WHEELSHikvisionHarry PotterGoProGucciGNCGolden GooseHugoGivenchyGEROVITALGiorgio ArmaniGuessGarminFortunaFerrero RocherGantGAPFURLAGeoxFENTY BEAUTYEstee LauderElectroluxEssenceEmporio ArmaniEccoDYSONElseveDr MartensDoTERRADoritosDunhillDurexDoppelherzEnglish HomeDJIDieselDeeZeeDiorDecathlonDelonghiDewaltDellCybexCroppDesigualDavid BeckhamCupioFarmasiCrocsColmarColumbiaCocosolisChristian DiorConverseChanelCifCarrefourcharlotte tilburyCarharttCeraVeCasioCartierCarolina HerreraBurberryCalvin KleinBritney SpearsBioSilBuffaloBirkenstockBoschBiodermaBALMAINBekoBatmanBalenciagaBepanthenBABY BREZZABarbieASOSBabylissArmaniBershkaASUSAriana GrandeAptamilAvonArielAntonio BanderasAmouageAsicsCOSAveneAmiriBigottiAppleAmdALEXANDER MCQUEENAlfaparfAldoAlwaysadidas

Sports & Outdoor

TennisTentPoolElectric BikeFootball JerseysElectric ScooterFootballBicycleBasketball ProductsSkateboardPilatesHoverboard

Books & Stationery

Pencil CasesNovelNotebooksFolderColoring BooksChildren's StorybooksBookmarkBooksColored PencilsBallpoint PensAgendaPuzzleManga

Multicolor Charger

5678+ item(s)
Choice KO-75 White US 5 Ports USB C PD Charger Quick Charge 3.0 Type C USB Ph...

Choice KO-75 White US 5 Ports USB C PD Charger Quick Charge 3.0 Type C USB Phone Chargers Fast Charging Ada

Lowest price in 14 days

Free shipping
Checkout Discount 25% Off

Lowest price in 14 days

Special Deals
29.74
22.30SAR
Choice KO-75 Black US 5 Ports USB C PD Charger Quick Charge 3.0 Type C USB Ph...

Choice KO-75 Black US 5 Ports USB C PD Charger Quick Charge 3.0 Type C USB Phone Chargers Fast Charging Ada

Lowest price in 14 days

Free shipping
Checkout Discount 25% Off

Lowest price in 14 days

Special Deals
29.85
22.39SAR
Choice7 EU 2 IN 1 Black PD 45W USB C Fast Charger For Samsung Galaxy S25 S23 ...

Choice EU 2 IN 1 Black PD 45W USB C Fast Charger For Samsung Galaxy S25 S23 S22 S21 S24 Ultra A35 A55 5G Ty

Lowest price in 30 days

Free shipping
Checkout Discount 25% Off

Lowest price in 30 days

Special Deals
37.53
28.15SAR
Choice black USB Charger Cord Compatible with Hatteker RFC-588 RSCX-7856 RFC-...

Choice black USB Charger Cord Compatible with Hatteker RFC-588 RSCX-7856 RFC-598 RFC-690 RFC-692 RSCX-9598

Lowest price in 7 days

Free shipping
Checkout Discount 25% Off

Lowest price in 7 days

Special Deals
24.52
18.39SAR
Choice EU Plug - 1.8m Cable 6A 67W Max Turbo EU Fast Charger for 11 12 13 14 ...

Choice EU Plug - 1.8m Cable 6A 67W Max Turbo EU Fast Charger for 11 12 13 14 Ultra Redmi Note 11T 12T 13 P

Lowest price in 14 days

Free shipping
Checkout Discount 25% Off

Lowest price in 14 days

Special Deals
40.38
30.28SAR
Choice US 40W (8-14 Serie) 40W For iPhone Charger USB Type C Fast Charger For...

Choice US 40W (8-14 Serie) 40W For iPhone Charger USB Type C Fast Charger For iPhone 16 15 14 13 12 11 Pro

4.0
(1)

Lowest price in 30 days

Free shipping
Checkout Discount 25% Off

Lowest price in 30 days

Special Deals
37.22
27.91SAR
Choice8 UK White 5 IN 1 GaN Desktop Charger For IPhone17 16Pro Laptop Samsung...

Choice UK White 5 IN 1 GaN Desktop Charger For IPhone17 16Pro Laptop Samsung 240W Fast Charging Adapter 10A

Lowest price in 30 days

Free shipping
Checkout Discount 25% Off

Lowest price in 30 days

Special Deals
29.37
22.03SAR
Choice BR Plug Ubigbuy 380W GaN USB C Charger PD 3.1 140W 100W PPS 45W Fast C...

Choice BR Plug Ubigbuy 380W GaN USB C Charger PD 3.1 140W 100W PPS 45W Fast Charging Station LCD Display fo

Free shipping
Checkout Discount 25% Off
Free shipping
Special Deals
252.48
189.36SAR
Choice EU Plug - 2m Cable 6A 120W EU Ultra Fast Charger For Xiaomi 11 12 13 1...

Choice EU Plug - 2m Cable 6A 120W EU Ultra Fast Charger For Xiaomi 11 12 13 14 15 Ultra Redmi Note 11 12 13

3.6
(65)
Review images available

Lowest price in 14 days

Free shipping
Checkout Discount 25% Off

Lowest price in 14 days

Special Deals
46.71
35.03SAR
Choice KR With 100W Cable ASOMETECH 160W USB Charging Station 7 in 1 Wireless...

Choice KR With 100W Cable ASOMETECH 160W USB Charging Station 7 in 1 Wireless Charger 65W 45W PPS PD Type C

5.0
(3)
Free shipping
Checkout Discount 25% Off
Free shipping
Special Deals
156.36
117.27SAR
Choice Blue Type C Charging Adapter For Garmin Fenix 8 7 7S 7X Instinct 3 2 2...

Choice Blue Type C Charging Adapter For Garmin Fenix 8 7 7S 7X Instinct 3 2 2s 2X Watch Charger Connector f

Lowest price in 30 days

Free shipping
Checkout Discount 25% Off

Lowest price in 30 days

Special Deals
24.95
18.71SAR
Alfanar 20W Fast USB Charger 1 Port Type C - Power Delivery Support (PD), GaN...

Alfanar 20W Fast USB Charger 1 Port Type C - Power Delivery Support (PD), GaN Technology

Free shipping

-9%

69.98
SAR
76.98
Choice1 65W AU Plug 55w 65w AU Plug Fast USB Charger Type C Charger for Xiaom...

Choice 65W AU Plug 55w 65w AU Plug Fast USB Charger Type C Charger for Xiaomi Redmi iPhone Samsung SmartPho

Lowest price in 14 days

Free shipping
Checkout Discount 25% Off

Lowest price in 14 days

Special Deals
41.25
30.94SAR
Choice Black-US 240W GaN 5 Port Fast Charging Station 3PD 2USB Desk Adapter F...

Choice Black-US 240W GaN 5 Port Fast Charging Station 3PD 2USB Desk Adapter For iPhone 17 16 15 Pro Samsung

Lowest price in 30 days

Free shipping
Checkout Discount 25% Off

Lowest price in 30 days

Special Deals
25.88
19.41SAR
Choice EU Plug Elough 45W USB Type C Phone Charger Super Fast Charge 2 Port W...

Choice EU Plug Elough 45W USB Type C Phone Charger Super Fast Charge 2 Port Wall Charger USB PD Adapter For

Lowest price in 30 days

Free shipping
Checkout Discount 25% Off

Lowest price in 30 days

Special Deals
31.92
23.94SAR
Choice EU Plug 240W GaN Charger 6-IN-1 140W PD3.1 PPS USB Type C Digital Disp...

Choice EU Plug 240W GaN Charger 6-IN-1 140W PD3.1 PPS USB Type C Digital Display Fast Charging Station for

Free shipping
Checkout Discount 25% Off
Free shipping
Special Deals
192.49
144.37SAR
Choice WHITE US 10W USB Foldable Wall Charger 5V 2A 2000mA Power Adapter Fold...

Choice WHITE US 10W USB Foldable Wall Charger 5V 2A 2000mA Power Adapter Folding US Plug UL FCC Certified T

4.9
(31)

Lowest price in 30 days

Free shipping
Checkout Discount 25% Off

Lowest price in 30 days

Special Deals
27.65
20.74SAR
Choice 1m cable EU Plug - 5A Cable PD 45W 5A Super Fast Charger for Samsung S...

Choice 1m cable EU Plug - 5A Cable PD 45W 5A Super Fast Charger for Samsung S21 S22 S23 S24 Plus Note20 Ult

4.4
(66)

Lowest price in 14 days

Free shipping
Checkout Discount 25% Off

Lowest price in 14 days

Special Deals
35.03
26.27SAR
Choice EU black Ultra-Slim 455W GaN Desktop Charger 5C2A Multi-Port Fast Char...

Choice EU black Ultra-Slim 455W GaN Desktop Charger 5C2A Multi-Port Fast Charging for Phones And Tablets Co

5.0
(1)
Free shipping
Checkout Discount 25% Off
Free shipping
Special Deals
168.99
126.74SAR
Choice3 Only 2m Cable 90W EU Ultra Fast Charger For Xiaomi 11 12 13 14 15 Ult...

Choice Only 2m Cable 90W EU Ultra Fast Charger For Xiaomi 11 12 13 14 15 Ultra 17 Redmi Note 11 12T 13 POCO

Lowest price in 30 days

Free shipping
Checkout Discount 25% Off

Lowest price in 30 days

Special Deals
24.61
18.46SAR
choice2 EU and 1.5m Cable 90W 6A Turbo Fast Wall Charger for Xiaomi 11 12 Lit...

Choice EU and 1.5m Cable 90W 6A Turbo Fast Wall Charger for Xiaomi 11 12 Lite 13T 14 Ultra Redmi Note 11T 1

Lowest price in 7 days

Free shipping
Checkout Discount 25% Off

Lowest price in 7 days

Special Deals
44.72
33.54SAR
choice2 EU 2IN1 (8-14 Serie) PD 40W For iPhone Charger USB C Chargers For iPh...

Choice EU 2IN1 (8-14 Serie) PD 40W For iPhone Charger USB C Chargers For iPhone 16 15 14 13 12 11 Pro XS Ma

Lowest price in 14 days

Free shipping
Checkout Discount 25% Off

Lowest price in 14 days

Special Deals
32.13
24.10SAR
choice2 White-EU 5 Ports USB C PD Charger Quick Charge 3.0 Type C USB Phone C...

Choice White-EU 5 Ports USB C PD Charger Quick Charge 3.0 Type C USB Phone Chargers Fast Charging Adapter F

Lowest price in 14 days

Free shipping
Checkout Discount 25% Off

Lowest price in 14 days

Special Deals
26.42
19.81SAR
Choice EU 2M (15-17 Series) PD 40W Phone Fast Charger For iPhone 17 16 15 14 ...

Choice EU 2M (15-17 Series) PD 40W Phone Fast Charger For iPhone 17 16 15 14 13 12 11 Pro Max 8 Plus iPad F

Lowest price in 14 days

Free shipping
Checkout Discount 25% Off

Lowest price in 14 days

Special Deals
38.49
28.87SAR
Alfanar 65W Fast USB Charger 3 Ports (2 Ports Type C & 1 Port Type A), Power ...

Alfanar 65W Fast USB Charger 3 Ports (2 Ports Type C & 1 Port Type A), Power Delivery Support (PD),

Free shipping
166
SAR
Choice 1M US Elough 6 USB Charger Power Strip Desktop Fast Charging EU/US Plu...

Choice 1M US Elough 6 USB Charger Power Strip Desktop Fast Charging EU/US Plug Wall Phone Charger Adapter E

Lowest price in 30 days

Free shipping
Checkout Discount 25% Off

Lowest price in 30 days

Special Deals
29.49
22.12SAR
Choice KR Plug Purple Gary 660W GaN USB C Charger Station 10 Port Fast Charge...

Choice KR Plug Purple Gary 660W GaN USB C Charger Station 10 Port Fast Charger Type C PD3.1 PD3.0 PPS Quick

Free shipping
Checkout Discount 25% Off
Free shipping
Special Deals
194.12
145.59SAR
Choice 1PCS KR Plug Pink 20W PD Korean USB C Type C Charger For iPhone 15 Fas...

Choice 1PCS KR Plug Pink 20W PD Korean USB C Type C Charger For iPhone 15 Fast Charging Cable For Xiaomi Re

Free shipping
Checkout Discount 25% Off
Free shipping
Special Deals
30.09
22.57SAR
Choice Korean Plug 240W GaN Charger 6-IN-1 140W PD3.1 PPS USB Type C Digital ...

Choice Korean Plug 240W GaN Charger 6-IN-1 140W PD3.1 PPS USB Type C Digital Display Fast Charging Station

Free shipping
Checkout Discount 25% Off
Free shipping
Special Deals
192.31
144.23SAR
Choice3 EU For iOS 2M Cable Original 35W Fast Charger Type C Data Cable For i...

Choice EU For iOS 2M Cable Original 35W Fast Charger Type C Data Cable For iPhone 11 12 13 14 15 16 17 Pro

Lowest price in 7 days

Free shipping
Checkout Discount 25% Off

Lowest price in 7 days

Special Deals
42.27
31.70SAR
Naxifly USB C Charger, 25W Fast Charge Wall Plug, 2 Ports PD&QC 3.0 Fast Char...

Naxifly USB C Charger, 25W Fast Charge Wall Plug, 2 Ports PD&QC 3.0 Fast Charger Plug Compatible for iPhone

Free shipping

-9%

79.28
SAR
87.21
Choice WHITE 8 in 1 USB Charging Station 25W PD Type C Power Strip Multi Port...

Choice WHITE 8 in 1 USB Charging Station 25W PD Type C Power Strip Multi Port Desktop HUB Phone Adapter For

Lowest price in 30 days

Free shipping
Checkout Discount 25% Off

Lowest price in 30 days

Special Deals
31.90
23.92SAR
Choice6 UK Yellow 5 IN 1 GaN Desktop Charger For IPhone17 16Pro Laptop Samsun...

Choice UK Yellow 5 IN 1 GaN Desktop Charger For IPhone17 16Pro Laptop Samsung 240W Fast Charging Adapter 10

Lowest price in 30 days

Free shipping
Checkout Discount 25% Off

Lowest price in 30 days

Special Deals
29.55
22.16SAR
Choice OnePlus 80W EU with 1M Original OnePlus SuperVOOC Charger 100W for One...

Choice OnePlus 80W EU with 1M Original OnePlus SuperVOOC Charger 100W for OnePlus 15T 13R 12 11 10 Nord 5 C

Lowest price in 30 days

Free shipping
Checkout Discount 25% Off

Lowest price in 30 days

Special Deals
66.94
50.20SAR
GENERAL Belkin USB Charger for iPhone 16 Samsung S25 Pixel 9 Single Port 45W ...

GENERAL Belkin USB Charger for iPhone 16 Samsung S25 Pixel 9 Single Port 45W Fast Charger

Free shipping
180.10
SAR
choice2 1m EU Charger 35w PD Fast Charger for iPhone 13 Pro 14 Plus 11 12 min...

Choice 1m EU Charger 35w PD Fast Charger for iPhone 13 Pro 14 Plus 11 12 mini XS Max XR X for iPad Air Quic

Lowest price in 30 days

Free shipping
Checkout Discount 25% Off

Lowest price in 30 days

Special Deals
27.48
20.61SAR
1...23...4647484950...94...138

Category

Promotional items

Price

Reviews with images

Quick Charge

Number of Ports

Local delivery

Cross promotions

Trendyol Plus

Seller type

merchant-badges-info-tooltip-approve-seller-title
Official seller
This badge is awarded to sellers of widely recognized local and international brands.
Star seller
This badge is awarded to sellers providing high customer satisfaction and offering reliable, high-quality service over the past 6 months.
What is seller type?