Men

SuitsMen BriefsBoxer Shorts

Home

White CarpetWallpaperWhite WallpaperToilet SeatsWhite NightstandsTablesPink CarpetParquetRugOffice DeskPaintPaintingsNightstandsIKEA DrapesGreen CarpetLightingGray WallpaperGray CarpetFurnitureDresserCouchDrapesChandelierChairsBlue CarpetBeige CarpetBathroom FurnitureBedXiaomi TelephoneSoundbarsTabletsXiaomi SmartwatchesSamsung SmartwatchesSSD HarddisksSpeakersSmartwatchesTelephoneSamsung TelephoneLENOVO LaptopsMotorola TelephoneLaptopsJBL SpeakersHuawei SmartwatchesHP LaptopsJBL HeadphonesHonor TelephoneDell LaptopsHeadphonesApple LaptopsApple SmartwatchesTelevisionPlaystation 5RouterMouseHuawei Laptops

Kids

PuppetsToysPhilips Avent Baby BottlesLANSINOH Baby BottlesKids Stroller & PushchairKids’ BikesKids SandalsKids Car SeatKids SneakersKids BootsKids ShoesKids SweatsuitsBaby BottlesBaby & Toddler ToysBarbie Puppets

Women

White DressesWhite T-ShirtsWatchesEarringsWhite JeansSwarovski JewelryTriumph BrasSwimsuitsSunglassesT-ShirtsTrousersSweatshirtsSwimsuitsEarringsRingsSweatpantsPandora JewelryPolo T-ShirtsKids WatchesPink DressesSkirtsPajamasSocksNike SweatpantsNecklacesKids PajamasKids SunglassesKids EarringsNike SocksNike T-ShirtsWhite TrousersKids Polo T-ShirtsMANGO DressesJeansEarringsShortsCharmsDressesJewelryBrasBlousesBlack JeansBlack Dressesadidas TrousersPandora RingsBikini

Beauty

ShampoosLip GlossesNailLashesMakeupLipsticksMascarasLattafa Fragrances and DeodorantsEyelinersFragrances and DeodorantsCollagenBlue NailBeautyAvon Fragrances and DeodorantsPhilips EpilatorEpilatorBraun Epilator

Electronics

Xiaomi Robot Vacuum CleanerVileda MopsWashing MachineVacuum CleanerRowenta Upright Vacuum CleanersUpright Vacuum CleanersRefrigeratorPhilips Upright Vacuum CleanersRobot Vacuum CleanerSandwich MakersPillowsMopsMultipurpose CookerMicrowave OvenFanDehumidifierFabric SoftenersBosch Upright Vacuum CleanersBedding SetRoborock Robot Vacuum CleanerMixerLeifheit Mops

Supermarket

Tchibo CoffeePistachioPastaLays ChipsLavAzza CoffeeJacobs CoffeeDavidoff CoffeeChipsCerealsCoffeeTurmericConfectioneryBulgurWater

Shoes & Bags

TEVA SandalsWhite SandalsWhite BootsTimberland BootsWhite Ballerina FlatsTommy Hilfiger SandalsSports ShoesWhite ShoesSkechers SandalsUGG BootsStilettosPuma BootsSandalsShoesLuggageBootsWalletsGeox BootsGold-colored SandalsNike CramponsGuess SandalsGold-colored ShoesEspadrillesLoafer ShoesCramponsCrocs AccessoryBum BagsBootsBrown ShoesBlack Ballerina FlatsBeige ShoesBeige SandalsBallerina FlatsBackpacksadidas BootsBagsCasual ShoesBlack ShoesSneakersadidas Sneakers

Popular Brands

ZzzquilXerjoffVera WangXiaomiTom TailorVivoYves Saint LaurentTissotVagabondValentinoVogueTakisTamagotchiUGGVichySupradynTESLASteve MaddenSPONGEBOBSinsayTom FordSkullcandyThe OrdinaryTommy HilfigerUnder ArmourStar WarsSanteSTIHLTriumphTimberlandYves RocherVersaceSephoraVivienne WestwoodSonicRemaxVansSamsoniteSol de JaneiroThe North FaceRoborockRoyal CaninSkechersTEFALStradivariusSudocremRAZERRed BullTCLRalph LaurenPringlesTchiboStanleyPeppa PigRedoxonSeikoPARKSIDESanoSHEINRitualsSamsungPandoraSwarovskiPHILIPP PLEINSalomonPalm AngelsRevoxPolaroidOsteocarePradaPaniniOppoNutellaONLYPrimarkPaco RabanneOneplusNintendoOriflameNutribulletPampersNextNokiaMYPROTEINPumaPhilipsStarbucksNespressoMoroccanoilMonclerOlaplexMontaleMoon BootPentiMilkaMomaxSpidermanMieleNikeMilwaukeeMilkshakeMylineMichelinMonopolyNew BalanceMichael KorsMaison MargielaMedicubeMotorolaLinexMakitaMayorallogitechMANGOMinisoMacLaysLC WaikikiLattafaLego NinjagoLanvinKinderLacosteL'OccitaneLaneigeKIKOLEGOLancomeKarl LagerfeldKerastaseJuicy CoutureLa Roche PosayK18LavAzzaJumboJORDANJimmy ChooISABEL MARANTJean Paul GaultierIVATHERMJBLLENOVOHugo BossHusqvarnaHuggiesIKEAKarcherhokaHuda BeautyHuaweiHonorHello KittyHermesHerbalifeHOT WHEELSHikvisionHarry PotterGoProGucciGNCGolden GooseHugoGivenchyGEROVITALGiorgio ArmaniGuessGarminFortunaFerrero RocherGantGAPFURLAGeoxFENTY BEAUTYEstee LauderElectroluxEssenceEmporio ArmaniEccoDYSONElseveDr MartensDoTERRADoritosDunhillDurexDoppelherzEnglish HomeDJIDieselDeeZeeDiorDecathlonDelonghiDewaltDellCybexCroppDesigualDavid BeckhamCupioFarmasiCrocsColmarColumbiaCocosolisChristian DiorConverseChanelCifCarrefourcharlotte tilburyCarharttCeraVeCasioCartierCarolina HerreraBurberryCalvin KleinBritney SpearsBioSilBuffaloBirkenstockBoschBiodermaBALMAINBekoBatmanBalenciagaBepanthenBABY BREZZABarbieASOSBabylissArmaniBershkaASUSAriana GrandeAptamilAvonArielAntonio BanderasAmouageAsicsCOSAveneAmiriBigottiAppleAmdALEXANDER MCQUEENAlfaparfAldoAlwaysadidas

Sports & Outdoor

TennisTentPoolElectric BikeFootball JerseysElectric ScooterFootballBicycleBasketball ProductsSkateboardPilatesHoverboard

Books & Stationery

Pencil CasesNovelNotebooksFolderColoring BooksChildren's StorybooksBookmarkBooksColored PencilsBallpoint PensAgendaPuzzleManga

Multicolor Charger

5688+ item(s)
Naxifly USB C Charger, 30W Fast Charge Wall Plug, 2 Ports PD&QC 3.0 Fast Char...

Naxifly USB C Charger, 30W Fast Charge Wall Plug, 2 Ports PD&QC 3.0 Fast Charger Plug Compatible for iPhone

Free shipping

-9%

86.52
SAR
95.17
Choice AU Plug-65W AU Plug Fast USB Charger Type C Charger for Xiaomi Redmi i...

Choice AU Plug-65W AU Plug Fast USB Charger Type C Charger for Xiaomi Redmi iPhone Samsung Mobile Phone Qui

Lowest price in 30 days

Free shipping
Checkout Discount 25% Off

Lowest price in 30 days

Special Deals
34.97
26.23SAR
Choice US With 100W Cable ASOMETECH GaN USB Type C Charger 65W 45W PPS PD QC4...

Choice US With 100W Cable ASOMETECH GaN USB Type C Charger 65W 45W PPS PD QC4.0 Quick Charger For Macbook L

Lowest price in 7 days

Free shipping
Checkout Discount 25% Off

Lowest price in 7 days

Special Deals
84.87
63.65SAR
Choice AU 45W USB-C Super Fast Charger Type C Wall Charging Block for Samsung...

Choice AU 45W USB-C Super Fast Charger Type C Wall Charging Block for Samsung Galaxy S23 Ultra/S23/S23+/S

4.8
(19)

Lowest price in 30 days

Free shipping
Checkout Discount 25% Off

Lowest price in 30 days

Special Deals
44.74
33.55SAR
Choice EU Plug USB C Charger 65W GaN Type C Fast Charging Phone Charger Adapt...

Choice EU Plug USB C Charger 65W GaN Type C Fast Charging Phone Charger Adapter For iPhone Samsung Xiaomi Q

Lowest price in 14 days

Free shipping
Checkout Discount 25% Off

Lowest price in 14 days

Special Deals
90.48
67.86SAR
choice2 Yellow-US 240W GaN 5 Port Fast Charging Station 3PD 2USB Desk Adapter...

Choice Yellow-US 240W GaN 5 Port Fast Charging Station 3PD 2USB Desk Adapter For iPhone 17 16 15 Pro Samsun

Lowest price in 30 days

Free shipping
Checkout Discount 25% Off

Lowest price in 30 days

Special Deals
25.88
19.41SAR
Choice5 White UK 240W 6 Port USB C PD Charger Super Fast Charging PD3.0 USB C...

Choice White UK 240W 6 Port USB C PD Charger Super Fast Charging PD3.0 USB C Type C Mobile Phone Charger Fo

Lowest price in 30 days

Free shipping
Checkout Discount 25% Off

Lowest price in 30 days

Special Deals
43.07
32.30SAR
Choice 33W EU USB A Charger For OPPO 33W Original USB Charger Fast Charging M...

Choice 33W EU USB A Charger For OPPO 33W Original USB Charger Fast Charging Mobile Plug Phone Charger Adapt

Lowest price in 14 days

Free shipping
Checkout Discount 25% Off

Lowest price in 14 days

Special Deals
33.51
25.13SAR
Vikefon With Cable White Dock Charger Adapter Wireless USB Fast Charging Cabl...

Vikefon With Cable White Dock Charger Adapter Wireless USB Fast Charging Cable Cord Stand For Watc

Lowest price in 14 days

Free shipping
Checkout Discount 25% Off

Lowest price in 14 days

Special Deals
35.71
26.78SAR
Choice1 Black-US 240W GaN 5 in 1 Fast Charging Phone Charger USB C Charger Po...

Choice Black-US 240W GaN 5 in 1 Fast Charging Phone Charger USB C Charger Power Adapter Type C EU/US Plug W

Lowest price in 14 days

Free shipping
Checkout Discount 25% Off

Lowest price in 14 days

Special Deals
25.91
19.43SAR
Choice10 toocki EU Purple Toocki 140W GaN USB Charger 5in1 Desktop Fast Charg...

Choice toocki EU Purple Toocki 140W GaN USB Charger 5in1 Desktop Fast Charge USB Type C Charger LED Display

Free shipping
Checkout Discount 25% Off
Free shipping
Special Deals
210.61
157.96SAR
Choice4 Only US Charger Original PD 68W Fast Charger For Samsung Xiaomi Onepl...

Choice Only US Charger Original PD 68W Fast Charger For Samsung Xiaomi Oneplus Google Motorola Moto USB C P

Lowest price in 14 days

Free shipping
Checkout Discount 25% Off

Lowest price in 14 days

Special Deals
45.55
34.16SAR
Choice8 toocki EU Blue Toocki 140W GaN USB Charger 5in1 Desktop Fast Charge U...

Choice toocki EU Blue Toocki 140W GaN USB Charger 5in1 Desktop Fast Charge USB Type C Charger LED Display C

Free shipping
Checkout Discount 25% Off
Free shipping
Special Deals
209.58
157.18SAR
Choice AU Charger and Cable AU Plug Quick Charging Block with Type-C Cable, 4...

Choice AU Charger and Cable AU Plug Quick Charging Block with Type-C Cable, 40W 4-Port USB Wall Adapter PD3

Lowest price in 30 days

Free shipping
Checkout Discount 25% Off

Lowest price in 30 days

Special Deals
41.48
31.11SAR
Choice black UK 65W Super Fast Charge Type C USB Phone Charger With Retractab...

Choice black UK 65W Super Fast Charge Type C USB Phone Charger With Retractable USB C Cable For Iphone 17 1

5.0
(1)

Lowest price in 14 days

Free shipping
Checkout Discount 25% Off

Lowest price in 14 days

Special Deals
43.61
32.71SAR
Naxifly USB C Charger, 25W Fast Charge Wall Plug, 2 Ports PD&QC 3.0 Fast Char...

Naxifly USB C Charger, 25W Fast Charge Wall Plug, 2 Ports PD&QC 3.0 Fast Charger Plug Compatible for iPhone

Free shipping

-9%

82.91
SAR
91.20
Choice US 1M (8-14 Series) PD 40W Phone Fast Charger For iPhone 17 16 15 14 1...

Choice US 1M (8-14 Series) PD 40W Phone Fast Charger For iPhone 17 16 15 14 13 12 11 Pro Max 8 Plus iPad Fa

Lowest price in 14 days

Free shipping
Checkout Discount 25% Off

Lowest price in 14 days

Special Deals
34.71
26.03SAR
Choice Grey Portable Headphone Charger Adapter for SHOKZ OpenSwim Pro S710 US...

Choice Grey Portable Headphone Charger Adapter for SHOKZ OpenSwim Pro S710 USB C Fast Charging Converter fo

Lowest price in 14 days

Free shipping
Checkout Discount 25% Off

Lowest price in 14 days

Special Deals
24.45
18.34SAR
Choice EU 1M (15-17 Series) PD 40W Phone Fast Charger For iPhone 17 16 15 14 ...

Choice EU 1M (15-17 Series) PD 40W Phone Fast Charger For iPhone 17 16 15 14 13 12 11 Pro Max 8 Plus iPad F

Lowest price in 14 days

Free shipping
Checkout Discount 25% Off

Lowest price in 14 days

Special Deals
35.06
26.29SAR
Choice EU 1M (8-14 Series) PD 40W Phone Fast Charger For iPhone 17 16 15 14 1...

Choice EU 1M (8-14 Series) PD 40W Phone Fast Charger For iPhone 17 16 15 14 13 12 11 Pro Max 8 Plus iPad Fa

Lowest price in 14 days

Free shipping
Checkout Discount 25% Off

Lowest price in 14 days

Special Deals
34.90
26.17SAR
Choice EU Plug 800W GaN Charger USB C Fast Desktop 10 Ports USB Type C PD Fas...

Choice EU Plug 800W GaN Charger USB C Fast Desktop 10 Ports USB Type C PD Fast Charging Station for iPhone

Free shipping
Checkout Discount 25% Off
Free shipping
Special Deals
159.58
119.68SAR
Choice KR Plug 800W GaN Charger USB C Fast Desktop 10 Ports USB Type C PD Fas...

Choice KR Plug 800W GaN Charger USB C Fast Desktop 10 Ports USB Type C PD Fast Charging Station for iPhone

Free shipping
Checkout Discount 25% Off
Free shipping
Special Deals
159.03
119.27SAR
Choice toocki EU Plug Toocki 25W GaN Charger USB C QC3.0 PD3.0 PPS Fast Charg...

Choice toocki EU Plug Toocki 25W GaN Charger USB C QC3.0 PD3.0 PPS Fast Charging for iPhone 18 17 16 Pro Ma

Lowest price in 30 days

Free shipping
Checkout Discount 25% Off

Lowest price in 30 days

Special Deals
34.15
25.61SAR
Eujgoov 40W Foldable Solar Panel Charger Monocrystalline Silicon with USB C F...

Eujgoov 40W Foldable Solar Panel Charger Monocrystalline Silicon with USB C Fast Charging Portable for RV Camping Outdoor Travel

Free shipping
189.58
SAR
Choice1 For Pixel watch 2 3 Black USB 3.3FT USB Charging Cable for Google Pix...

Choice For Pixel watch 2 3 Black USB 3.3FT USB Charging Cable for Google Pixel Watch 2/ Watch 3 Charger Rep

Lowest price in 7 days

Free shipping
Checkout Discount 25% Off

Lowest price in 7 days

Special Deals
28.59
21.44SAR
Choice1 UK 20W PD Dual Ports Wall Charger Type-C USB C PD Phone Fast Charger ...

Choice UK 20W PD Dual Ports Wall Charger Type-C USB C PD Phone Fast Charger Super Quick Charging Power Adap

Lowest price in 30 days

Free shipping
Checkout Discount 25% Off

Lowest price in 30 days

Special Deals
34.22
25.66SAR
choice2 EU A C Gallium Nitride 45W PD Fast Charger: Ultra-Thin, Portable, Spa...

Choice EU A C Gallium Nitride 45W PD Fast Charger: Ultra-Thin, Portable, Space-Saving, Compatible with Appl

Lowest price in 14 days

Free shipping
Checkout Discount 25% Off

Lowest price in 14 days

Special Deals
67.06
50.29SAR
Choice1 US 40w Charger Single Ports Type-C PD40w Fast Charging Phone Adapter ...

Choice US 40w Charger Single Ports Type-C PD40w Fast Charging Phone Adapter For iPhone 15-17 Xiaomi Samsung

Lowest price in 14 days

Free shipping
Checkout Discount 25% Off

Lowest price in 14 days

Special Deals
34.16
25.62SAR
Choice black USB Charger Cord Compatible with Hatteker RFC-588 RSCX-7856 RFC-...

Choice black USB Charger Cord Compatible with Hatteker RFC-588 RSCX-7856 RFC-598 RFC-690 RFC-692 RSCX-9598

Lowest price in 7 days

Free shipping
Checkout Discount 25% Off

Lowest price in 7 days

Special Deals
24.52
18.39SAR
Choice US White 65W USB Phone Charger With Retractable Super Fast Charging Ty...

Choice US White 65W USB Phone Charger With Retractable Super Fast Charging Type C Cable For iPhone 17 16 PO

Lowest price in 14 days

Free shipping
Checkout Discount 25% Off

Lowest price in 14 days

Special Deals
43.77
32.83SAR
Choice EU With 100W Cable ASOMETECH GaN USB Type C Charger 65W 45W PPS PD QC4...

Choice EU With 100W Cable ASOMETECH GaN USB Type C Charger 65W 45W PPS PD QC4.0 Quick Charger For Macbook L

Lowest price in 14 days

Free shipping
Checkout Discount 25% Off

Lowest price in 14 days

Special Deals
84.76
63.57SAR
Choice Korea Plug White ASOMETECH 67W GaN Charger Ultra Thin Quick Charge QC3...

Choice Korea Plug White ASOMETECH 67W GaN Charger Ultra Thin Quick Charge QC3.0 PD PPS Mini USB Type C Char

Free shipping
Checkout Discount 25% Off
Free shipping
Special Deals
93.48
70.11SAR
choice2 US Grey USB 150W Charger 3 Ports Type C Fast Charging Mobile Phone Ch...

Choice US Grey USB 150W Charger 3 Ports Type C Fast Charging Mobile Phone Charger PD QC3.0 Adapter For iPho

Lowest price in 14 days

Free shipping
Checkout Discount 25% Off

Lowest price in 14 days

Special Deals
38.41
28.81SAR
Choice7 Black-EU 240w Gan Fast Charger With Led Light 5 In 1 2usb+3type-C Mul...

Choice Black-EU 240w Gan Fast Charger With Led Light 5 In 1 2usb+3type-C Multi Port Phone Charger For Iphon

Free shipping
Checkout Discount 25% Off
Free shipping
Special Deals
30.23
22.67SAR
Choice1 Yellow Universal Cute Cat Type-C Fully Charged Smart Separator Auto P...

Choice Yellow Universal Cute Cat Type-C Fully Charged Smart Separator Auto Power-Off Overcharge Protection

Lowest price in 30 days

Free shipping
Checkout Discount 25% Off

Lowest price in 30 days

Special Deals
45.49
34.12SAR
Choice EU With 100W Cable ASOMETECH GaN USB Type C Charger 65W 45W PPS PD QC4...

Choice EU With 100W Cable ASOMETECH GaN USB Type C Charger 65W 45W PPS PD QC4.0 Quick Charger For Macbook L

Lowest price in 14 days

Free shipping
Checkout Discount 25% Off

Lowest price in 14 days

Special Deals
88.38
66.28SAR
1...24...4748495051...94...138

Category

Promotional items

Price

Reviews with images

Quick Charge

Number of Ports

Local delivery

Cross promotions

Trendyol Plus

Seller type

merchant-badges-info-tooltip-approve-seller-title
Official seller
This badge is awarded to sellers of widely recognized local and international brands.
Star seller
This badge is awarded to sellers providing high customer satisfaction and offering reliable, high-quality service over the past 6 months.
What is seller type?